summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2babfaa186d3..8d6181c5cc4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=time-to-leave-bin
-_pkgname="Time to Leave"
+_pkgname='Time to Leave'
pkgver=3.0.0
_electronversion=11
-pkgrel=7
-pkgdesc="Log work hours and get notified when it's time to leave the office and start to live.Use system-wide electron."
+pkgrel=8
+pkgdesc="Log work hours and get notified when it's time to leave the office and start to live.(Prebuilt version.Use system-wide electron)"
arch=('x86_64')
url="http://timetoleave.app/"
-_ghurl="https://github.com/thamara/time-to-leave"
+_ghurl="https://github.com/TTLApp/time-to-leave"
license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
@@ -15,20 +15,19 @@ depends=(
"electron${_electronversion}"
)
source=(
- "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-amd64.deb"
+ "${pkgname%-bin}-${pkgver}.rpm::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-amd64.rpm"
"${pkgname%-bin}.sh"
)
-sha256sums=('cb545e917262e4263c59baa95a2b995d4aac7370bf623ce2b715d4b5d819f45a'
+sha256sums=('97b3490bb3f6337df84df0930eeb964addf8a96af983a67dd6089c60c41ac6db'
'291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
-build() {
- sed -e "
+prepare() {
+ sed -i -e "
s/@electronversion@/${_electronversion}/g
s/@appname@/${pkgname%-bin}/g
s/@runname@/app.asar/g
s/@cfgdirname@/${_pkgname}/g
s/@options@//g
- " -i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data."*
+ " "${srcdir}/${pkgname%-bin}.sh"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"