summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 955249e70a1e..3e7e3433df5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: r6eve <r6eve at acm dot org>
pkgname=tmux-tanlog-bin
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc='Save all console outputs into files'
arch=('x86_64')
@@ -10,10 +10,11 @@ license=('Boost')
depends=('tmux' 'zsh')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-source=("${url}/releases/download/${pkgver}/${pkgname%-bin}-${CARCH}-unknown-linux-musl")
-sha256sums=('a024ec1f0f5514cfcaea3debed9fc82abfd32fc4a664daf8d8be078f3a86cf2a')
+source=("${pkgname}-${pkgver}"::"${url}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-${CARCH}-unknown-linux-musl")
+noextract=("${pkgname}-${pkgver}")
+sha256sums=('fa23c16b70ea3a1ca647067df21a652dbb2e0a57dc337b0d2d44e57105c12682')
package() {
- mv "${pkgname%-bin}-${CARCH}-unknown-linux-musl" "${pkgname%-bin}"
+ mv "${pkgname}-${pkgver}" "${pkgname%-bin}"
install -Dm0755 -t "${pkgdir}/usr/bin/" "${pkgname%-bin}"
}