summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81d13ebfac3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=tzsp2pcap-git
+pkgver=r16.e2e5d91
+pkgrel=1
+pkgdesc="Simple live TaZmen Sniffer Protocol (TZSP) to pcap converter"
+arch=('i686' 'x86_64')
+url="https://github.com/thefloweringash/tzsp2pcap"
+license=('BSD')
+groups=('network')
+depends=('libpcap')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/thefloweringash/tzsp2pcap.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ LDFLAGS="-D_DEFAULT_SOURCE" make
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 tzsp2pcap "$pkgdir/usr/bin/tzsp2pcap"
+}
+
+# vim:set ts=2 sw=2 et: