summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d38705b463f6..6dd29f1e56bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
# Contributor: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
pkgname=udev-notify-bzr
-pkgver=32
+pkgver=40
pkgrel=1
pkgdesc="Visual hardware notifications for Linux. (Bazaar version)"
arch=('i686' 'x86_64')
url="https://launchpad.net/udev-notify"
license=('GPL3')
-depends=('notification-daemon' 'python2' 'python2-udev' 'python2-notify')
+depends=('python-pyudev'
+ 'python-notify2'
+ )
makedepends=('bzr')
conflicts=('udev-notify')
provides=('udev-notify')
-source=('udev-notify::bzr+lp:udev-notify')
-sha1sums=('SKIP')
+source=('udev-notify::bzr+lp:~i026e/udev-notify/python3')
+sha256sums=('SKIP')
pkgver() {
cd udev-notify
@@ -22,9 +24,10 @@ pkgver() {
prepare() {
# Prepare Makefile
- sed -e 11d -e '/debian-package.sh/d' -e '/pyudev/d' -e 's|\./build/debian|$(DESTDIR)|g' -i udev-notify/Makefile
- # Force use python2
- sed 's|env python|env python2|g' -i udev-notify/src/udev-notify.py
+ sed -e 11d \
+ -e '/debian-package.sh/d' \
+ -e 's|\./build/debian|$(DESTDIR)|g' \
+ -i udev-notify/Makefile
}
package() {