summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7530d2218c9..12343e907218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
pkgname=ufodiff
pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc='UFO source file diff application'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
license=(MIT)
+_pydeps=(commandlines
+ gitdb
+ gitpython
+ smmap
+ standardstreams)
depends=(python
- python-commandlines
- python-gitdb
- python-gitpython
- python-smmap
- python-standardstreams)
+ "${_pydeps[@]/#/python-}")
makedepends=(python-{build,installer,wheel}
python-setuptools)
_archive="$pkgname-$pkgver"
-source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('e549e7f3598c0cf0a6be207944fb632db0d834addb4cf202ee00967ceebd58dd')
build() {