summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95388856b468..3a8cd65cd5eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,28 @@
-# Maintainer: Alif Uzair bin Abd Rahman <riazufila at gmail dot com>
+# Maintainer:
+# Contributor: FabioLolix
+# Contributor: Alif Uzair bin Abd Rahman <riazufila at gmail dot com>
# Contributor: Cole Thompson <cole dot thompson at gmail dot com>
+
pkgname=ufw-icon-bar
-pkgver=1
-pkgrel=6
+pkgver=r15.gbf67a93
+pkgrel=1
+epoch=1
pkgdesc="System tray icon for ufw"
arch=('any')
url="https://github.com/juanmafont/ufwIconbar"
license=('unknown')
depends=('yad' 'ufw')
+makedepends=(git)
optdepends=('gufw: Enables gufw to open when icon is clicked')
-source=("$pkgname-$pkgver::git+https://github.com/juanmafont/ufwIconbar.git")
-md5sums=("SKIP")
+source=("git+https://github.com/juanmafont/ufwIconbar.git#commit=bf67a93ce02543d4d4472eabd822da495a0de9b1")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/ufwIconbar"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- install -Dm 755 "$srcdir/$pkgname-$pkgver/gufw_icon.sh" "$pkgdir/usr/bin/gufw_icon.sh"
+ cd "${srcdir}/ufwIconbar"
+ install -Dm755 gufw_icon.sh "$pkgdir/usr/bin/gufwicon"
}