summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..570a5fba946e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Cihan Alkan <cihanalk@gmail.com>
+
+pkgname=ukui-desktop
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="UKUI Masaüstü"
+url="https://ukui-desktop.org"
+arch=('x86_64')
+license=('GPL')
+depends=('gtk3' 'ukwm' 'startup-notification')
+makedepends=('gobject-introspection' 'intltool')
+optdepends=()
+groups=('ukui')
+source=("git+https://github.com/ukui/ukui-desktop.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}
+ ./configure \
+ --prefix=/usr \
+ --disable-schemas-compile
+
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}