summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d72e4891a2b..81882eac52e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname=unison-232-compat
_pkgname=unison
pkgver=2.32.52
_pkgver=232
-pkgrel=1
+pkgrel=2
pkgdesc="File-synchronization tool (legacy 2.32 version). Compatible with parallel installation to other versions of unison binaries (but pay attention to the local user configurations!)"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -27,24 +27,33 @@ url="http://www.cis.upenn.edu/~bcpierce/unison"
provides=("unison-232=${pkgver}")
optdepends=('gtk2: for the GTK2 frontend')
makedepends=('ocaml' 'lablgtk2' 'imagemagick' 'gtk2')
-source=("http://www.cis.upenn.edu/~bcpierce/$_pkgname/download/releases/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz"
- "$_pkgname-ssh-ocaml.patch"
- "$_pkgname-$_pkgver.desktop")
-md5sums=('0701f095c1721776a0454b94607eda48'
- '81a28349471434c75a4206d07ad21eb1'
- '2ab7bb57623e786936d892ddc228c2f8')
+source=(
+ "http://www.cis.upenn.edu/~bcpierce/$_pkgname/download/releases/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz"
+ "http://www.cis.upenn.edu/~bcpierce/$_pkgname/download/releases/$_pkgname-$pkgver/$_pkgname-$pkgver-manual.html"
+ "http://www.cis.upenn.edu/~bcpierce/$_pkgname/download/releases/$_pkgname-$pkgver/$_pkgname-$pkgver-manual.pdf"
+ "$_pkgname-$_pkgver.desktop::http://ix.io/2ktj"
+ "$_pkgname-ssh-ocaml.patch::http://ix.io/2ktk"
+ )
+sha256sums=(
+ '1542e5d4ad03e928260e061a8ff9d5e0bca3282481ed8bec5552de17a0270485'
+ 'c898239d8139d8405b96d87e12c06c7f41fd3629cac0c83bc338aad50fed7f81'
+ 'b3fee7ac99907f3b1ed02c6ac901678e82ea1eed936acb45e9735b95d55cc4eb'
+ '367f4572b98dbaa336fbc31368456c0840fe754d09370c714477b5e8140a28e8'
+ '02281d37ddea74108ce5a5d81b62b997266ec9ab2aac520b4403b57964c72dfa'
+ )
options=(!makeflags)
-# Comment out the very last 2 lines if you want to install
-# side-by-side with other versions.
-build() {
- # Move into the source directory
+prepare() {
cd $srcdir/$_pkgname-$pkgver
- CFLAGS=""
-
# Apply SSH Ocaml patch
patch -Np1 -i "../$_pkgname-ssh-ocaml.patch"
+}
+
+build() {
+ # Move into the source directory
+ cd $srcdir/$_pkgname-$pkgver
+ CFLAGS=""
# Compile Unison 2.32 command-line version
make clean
@@ -77,7 +86,7 @@ package() {
# Install the .desktop menu file, which can launch the GTK2 version
install -Dm644 "../$_pkgname-$_pkgver.desktop" "$pkgdir/usr/share/applications/$_pkgname-$_pkgver.desktop"
-
+
# Make a symbolic link named "unison-232-x11" that points to "unison-232-gtk2"; not required, but good for scripting / compatibility reasons
cd "$pkgdir/usr/bin/"
ln -s "$_pkgname-$_pkgver-gtk2" "$_pkgname-$_pkgver-x11"