summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b546898d39b..01e571af78eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=util-linux-selinux
pkgname=(util-linux-selinux libutil-linux-selinux)
-pkgver=2.25
+pkgver=2.25.1
pkgrel=1
pkgdesc="SELinux aware miscellaneous system utilities for Linux"
url="http://www.kernel.org/pub/linux/utils/util-linux/"
@@ -19,27 +19,17 @@ groups=('selinux')
# systemd depends on libutil-linux and util-linux depends on libudev
# provided by libsystemd (FS#39767). To break this cycle, make
# util-linux-selinux depend on systemd at build time.
-makedepends=('systemd' 'python')
+makedepends=('systemd' 'python' 'libselinux')
license=('GPL2')
options=('strip' 'debug')
source=("ftp://ftp.kernel.org/pub/linux/utils/${pkgname/-selinux}/v2.25/${pkgname/-selinux}-$pkgver.tar.xz"
uuidd.tmpfiles
- pam-login
- pam-common
- pam-su
- 0001-fdisk-fix-l-device.patch)
-md5sums=('4c78fdef4cb882caafad61e33cafbc14'
+ pam-{login,common,su})
+md5sums=('2ff36a8f8ede70f66c5ad0fb09e40e79'
'a39554bfd65cccfd8254bb46922f4a67'
'4368b3f98abd8a32662e094c54e7f9b1'
'a31374fef2cba0ca34dfc7078e2969e4'
- 'fa85e5cce5d723275b14365ba71a8aad'
- '93cf977a7abc6f30152295e2aef453fa')
-
-prepare() {
- cd "${pkgname/-selinux}-$pkgver"
-
- patch -Np1 <"$srcdir"/0001-fdisk-fix-l-device.patch
-}
+ 'fa85e5cce5d723275b14365ba71a8aad')
build() {
cd "${pkgname/-selinux}-$pkgver"
@@ -112,6 +102,7 @@ package_libutil-linux-selinux() {
pkgdesc="util-linux-selinux runtime libraries"
provides=('libblkid.so' 'libmount.so' 'libsmartcols.so' 'libuuid.so'
"${pkgname/-selinux}=${pkgver}-${pkrel}")
+ depends=('libselinux')
conflicts=("${pkgname/-selinux}")
mv "$srcdir/_libutil-linux"/* "$pkgdir"