summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 522a8f143b3d..13c06dac9924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=cnr2
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.2.g1f2c901
+pkgver=1.2.g1f2c901
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,22 +14,23 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth