summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbbb3e5e4871..195e99855d3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=deblockpp7
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r4.1.0.g24bf2fc
+pkgver=4.1.1.g533c7e4
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,22 +14,23 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DeblockPP7.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d r)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth