summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5722248dc2ae..c33f67523174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,6 @@
# Removed cuda as a requirement
# Removed undeeded cmake flags
# Removed c compiler flags overide
-# Moved build folder to inside clone
_plug=dfttest2
pkgname=vapoursynth-plugin-dfttest2-cpu-git
@@ -18,7 +17,7 @@ arch=('x86_64')
url='https://github.com/AmusementClub/vs-dfttest2'
license=('GPL2')
depends=('vapoursynth')
-makedepends=('git' 'cmake' 'ninja' 'gcc11' 'unzip')
+makedepends=('git' 'cmake' 'ninja' 'gcc11')
provides=("vapoursynth-plugin-dfttest2-cpu")
conflicts=("vapoursynth-plugin-dfttest2" "vapoursynth-plugin-dfttest2-git")
source=("${_plug}::git+https://github.com/AmusementClub/vs-dfttest2")
@@ -33,34 +32,28 @@ pkgver() {
}
prepare() {
- # Download vector class library
cd "${_plug}"
-
- rm -rf vectorclass version2*
- wget -q -O vcl.zip https://github.com/vectorclass/version2/archive/refs/tags/v2.01.04.zip
- unzip -q vcl.zip
- mv version2*/ vectorclass
+ git submodule update --init --recursive
}
build() {
# This is based on what the project's CI is doing
- cd "${_plug}"
-
export CXX=g++-11
cmake \
-B "build" \
+ -S "${_plug}" \
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_COMPILER="${CXX}" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS_RELEASE="-ffast-math -march=native" \
-DENABLE_CUDA=0 \
- -DVCL_HOME="$(pwd)/vectorclass" \
-Wno-dev
cmake --build "build" --config Release
}
package() {
- DESTDIR="$pkgdir" cmake --install "${_plug}/build"
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"