summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 250cf1783359..24deab74c4fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=r39.22a40af
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/VFR-maniac/VapourSynth-TNLMeans'
license=('GPL')
depends=('vapoursynth')
@@ -13,7 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/VFR-maniac/VapourSynth-TNLMeans.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -22,19 +22,23 @@ pkgver() {
}
prepare() {
- rm -fr "${_plug}/VapourSynth.h"
+ cd "${_plug}"
+ rm -fr VapourSynth.h
}
build() {
cd "${_plug}"
- ./configure --prefix=/usr \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --prefix=/usr \
+ --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
+
make
}
package(){
cd "${_plug}"
make DESTDIR="${pkgdir}" install
+
install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}