summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 489cc27f7cac..9303b4d0b106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,27 @@
_plug=vsgan
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=1.6.4.61.gfbb606c
+pkgver=1.6.4.117.g6f9d76b
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url='https://github.com/rlaPHOENiX/VSGAN'
license=('MIT')
-depends=('vapoursynth-plugin-mvsfunc-git'
- 'python-numpy'
- )
-makedepends=('git'
- 'python-pip'
- )
-optdepends=('python-pytorch: CPU with AVX2 optimizations'
- 'python-pytorch-cuda: CUDA with CPU with AVX2 optimizations'
- )
+depends=(
+ 'vapoursynth-plugin-mvsfunc-git'
+ 'python-numpy'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-wheel'
+ 'python-installer'
+ 'python-setuptools'
+)
+optdepends=(
+ 'python-pytorch: CPU with AVX2 optimizations'
+ 'python-pytorch-cuda: CUDA with CPU with AVX2 optimizations'
+)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/rlaPHOENiX/VSGAN.git")
@@ -28,13 +34,13 @@ pkgver() {
}
build() {
- cd "${_plug}"
- pip wheel --no-deps . -w dist
+ cd "${srcdir}/${_plug}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${_plug}"
- pip install -I -U --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+ cd "${srcdir}/${_plug}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"