summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 37 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 872dc1b082cc..25571cb89cc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,40 @@
_plug=waifu2x-caffe
pkgname=vapoursynth-plugin-${_plug}-git
pkgver=14.1.g89f5401
-pkgrel=2
+pkgrel=3
pkgdesc="Plugin for Vapoursynth: ${_plug} (NVIDIA users only)(static libcaffe)(GIT version)"
arch=('x86_64')
url='https://forum.doom9.org/showthread.php?t=173673'
license=('MIT')
-depends=('vapoursynth'
- 'libboost_iostreams.so'
- 'libopenblas'
- 'google-glog'
- 'gflags'
- 'hdf5'
- 'protobuf'
- 'cudnn'
- 'opencv'
- 'nvidia-utils'
- )
-makedepends=('git'
- 'boost'
- 'meson'
- 'cuda'
- )
+depends=(
+ 'vapoursynth'
+ 'boost-libs' 'libboost_iostreams.so'
+ 'openblas'
+ 'google-glog'
+ 'gflags'
+ 'hdf5'
+ 'protobuf'
+ 'cudnn'
+ 'opencv'
+ 'nvidia-utils'
+ 'abseil-cpp'
+)
+makedepends=(
+ 'git'
+ 'boost'
+ 'meson'
+ 'cuda'
+)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Waifu2x-caffe.git"
- 'git+https://github.com/HolyWu/caffe.git#branch=lltcggie/custom'
- )
-sha256sums=('SKIP'
- 'SKIP'
- )
+source=(
+ "${_plug}::git+https://github.com/sl1pkn07/VapourSynth-Waifu2x-caffe.git"
+ 'git+https://github.com/sl1pkn07/caffe.git#branch=lltcggie/custom'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
options=('debug')
pkgver() {
@@ -40,7 +45,7 @@ pkgver() {
}
prepare() {
- mkdir -p fakeroot build
+ mkdir -p fakeroot
# CUDA 11.6.x not support compute_30/35/37 (Kepler boards)
# CUDA 11.6.x add support to new boards (Ampere boards)
@@ -63,8 +68,8 @@ prepare() {
sed -e '/USE_CUDNN/s/^/#/' \
-i caffe/Makefile.config
- # c++11 -> c++14
- sed 's|c++11|c++14|g' \
+ # c++11 -> c++17
+ sed 's|c++11|c++17|g' \
-i caffe/Makefile
cd "${_plug}"
@@ -75,17 +80,16 @@ prepare() {
build() {
cd caffe
- NVCC_APPEND_FLAGS="-Wno-deprecated-gpu-targets" \
+ NVCC_APPEND_FLAGS="-Wno-deprecated-gpu-targets -D_Float32=__Float32 -D_Float64=__Float64 -D_Float128=__Float128 -D_Float32x=__Float32x -D_Float64x=__Float64x" \
make lib
install -Dm644 build/lib/libcaffe.a "${srcdir}/fakeroot/lib/libcaffe.a"
cp -R include "${srcdir}/fakeroot"
install -Dm644 build/src/caffe/proto/caffe.pb.h "${srcdir}/fakeroot/include/caffe/proto/caffe.pb.h"
- cd "${srcdir}/build"
-
- CXXFLAGS+=' -fpermissive'
- arch-meson "../${_plug}" \
+ cd "${srcdir}"
+ CXXFLAGS+=' -fpermissive -std=c++17'
+ arch-meson "${_plug}" build \
-Dcudaincludedir=/opt/cuda/include \
-Dcudalibdir=/opt/cuda/lib64 \
-Dcaffe_includedir="$(readlink -e "${srcdir}/fakeroot/include")" \
@@ -93,11 +97,11 @@ build() {
--buildtype=release \
-Db_lto=false
- ninja
+ meson compile -C build
}
package(){
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
mv "${pkgdir}/usr/lib/vapoursynth/models" "${pkgdir}/usr/lib/vapoursynth/${_plug}-models"