summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c834333dda84..4ab72f25c0ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
pkgname=vcf-validator
-pkgver=0.6
-pkgrel=2
+pkgver=0.7
+pkgrel=1
pkgdesc="Validation suite for Variant Call Format (VCF) files"
-arch=('i686' 'x86_64')
-url=https://github.com/EBIvariation/vcf-validator
+arch=('x86_64')
+url=https://github.com/EBIvariation/"${pkgname}"
license=('Apache')
depends=('libpthread-stubs' 'libodb-sqlite' 'odb')
makedepends=('cmake' 'boost')
source=("${pkgname}"-"${pkgver}".tar.gz::https://github.com/EBIvariation/"${pkgname}"/archive/v"${pkgver}".tar.gz)
-sha256sums=('9ae64caea3439feed1f24268d82610f90dac6578169e0d87f82caeb7c349dadc')
+sha256sums=('da0cb126e2dad6f79a8ec503f02addf0b4e437f072e44a1cf832e64f0806d019')
prepare() {
mkdir -p build
- sed -i '/include_directories (lib)/ a link_directories ("/usr/lib/odb/")' "${pkgname}-${pkgver}"/CMakeLists.txt
+ # Cmake cannot located `libodb-sqlite` and `odb` libraries so patch it in.
+ # Many thanks to the community for this small fix:
+ # https://bbs.archlinux.org/viewtopic.php?id=234124
+ #
+ sed -i \
+ '/include_directories (lib)/ a link_directories ("/usr/lib/odb/")' \
+ "${pkgname}-${pkgver}"/CMakeLists.txt
}
build() {
@@ -24,8 +30,9 @@ build() {
}
package() {
- install -Dm755 build/bin/vcf_validator "${pkgdir}"/usr/bin/vcf_validator
- install -Dm755 build/bin/vcf_debugulator "${pkgdir}"/usr/bin/vcf_debugulator
+ cd build
+ install -Dm755 bin/vcf_validator "${pkgdir}"/usr/bin/vcf_validator
+ install -Dm755 bin/vcf_debugulator "${pkgdir}"/usr/bin/vcf_debugulator
cd "${srcdir}"/"${pkgname}"-"${pkgver}"
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE