summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 153a5353c3dc..9ae520de0c9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Berseker <berseker86 at gmail.com>
pkgname=viewnior-git
-pkgver=1.7.r2.gaac0a0c
+pkgver=1.8.r0.g4a4c6e8
pkgrel=1
pkgdesc="Simple, fast, elegant and minimalistic image viewer, written in C(GTK+) with a new GtkImageView library. Git Version"
arch=('i686' 'x86_64')
@@ -12,8 +12,14 @@ depends=('exiv2' 'gtk2')
makedepends=('gnome-common' 'intltool' 'meson' 'ninja')
provides=('viewnior')
conflicts=('viewnior')
-source=("${pkgname}::git+https://github.com/hellosiyan/Viewnior.git")
-md5sums=('SKIP')
+source=(
+ "${pkgname}::git+https://github.com/hellosiyan/Viewnior.git"
+ 'https://patch-diff.githubusercontent.com/raw/hellosiyan/Viewnior/pull/130.patch'
+)
+md5sums=(
+ 'SKIP'
+ '975eeae744a613e326b89b5dd4ef1fbe'
+)
pkgver()
{
@@ -21,6 +27,10 @@ pkgver()
git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/viewnior.//'
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/130.patch"
+}
build()