summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aed71500492a..cf066057be57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: George Angelopoulos <george@usermod.net>
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+# Contributor: George Angelopoulos <george@usermod.net>
+
pkgname=vim-colorscheme-alduin
-pkgver=3.0.0
-pkgrel=2
+pkgver=6.0.0
+pkgrel=1
pkgdesc="A dark low-contrast Vim colorscheme for Terminal Vim and GUI Vim."
arch=('any')
url="https://github.com/AlessandroYorba/Alduin"
license=('MIT')
-source=("https://github.com/AlessandroYorba/Alduin/archive/v.${pkgver}.tar.gz")
-md5sums=('6165e7167bd8596a4e13135b17ff459b')
-_name=Alduin
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AlessandroYorba/Alduin/archive/v${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('eed9003b5ff421a005e13215b847718b'
+ 'b1649899e6ed82950e52f46a3e9656de')
package() {
- cd "$_name-v.$pkgver"
- install -Dm644 colors/alduin.vim "$pkgdir/usr/share/vim/vim80/colors/alduin.vim"
-}
+ install -Dm755 "Alduin-${pkgver}/colors/alduin.vim" \
+ "$pkgdir/usr/share/vim/vimfiles/colors/alduin.vim"
+ install -Dm755 "Alduin-${pkgver}/autoload/airline/themes/alduin.vim" \
+ "${pkgdir}/usr/share/vim/vimfiles/autoload/airline/themes/alduin.vim"
-# vim:set ts=2 sw=2 et:
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}