summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61afa9979f6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Maxwell Pray <synthead@gmail.com>
+
+_pkgname=file-line
+pkgname=vim-$_pkgname-git
+pkgver=r72.9233f66
+pkgrel=1
+pkgdesc="Plugin for Vim to enable opening files with the file:line:column syntax"
+arch=("any")
+url="https://github.com/patnr/file-line"
+license=("GPL3")
+source=("git+https://github.com/patnr/file-line.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm 644 "$srcdir/$_pkgname/plugin/file_line.vim" "$pkgdir/usr/share/vim/vimfiles/plugin/file_line.vim"
+ install -Dm 644 "$srcdir/$_pkgname/README.md" "$pkgdir/usr/share/doc/README.md"
+}