summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90d0a5d70766..fff8bd928d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,25 @@ url="http://www.catb.org/~esr/vms-empire/"
license=('GPL')
depends=('ncurses')
makedepends=('xmlto')
-source=(
- http://www.catb.org/~esr/$pkgname/$pkgname-$pkgver.tar.gz
-)
+source=("http://www.catb.org/~esr/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('9defc2be52380171f293b5bfb4c5fa28')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
sed -i 's/^install: empire.6 uninstall/install: empire.6/' Makefile
+
+ # gcc10 tweaks
+ sed -i 's/^.*user_obj.*$/static &/' extern.h
+ sed -i 's/^.*comp_obj.*$/static &/' extern.h
+ sed -i 's/^.*automove.*$/static &/' extern.h
+ sed -i 's/^view_map_t .*$/static &/' extern.h
+ sed -i 's/^real_map_t .*$/static &/' extern.h
+ sed -i 's/^int [^(]*$/static &/' extern.h
+ sed -i 's/^long [^(]*$/static &/' extern.h
+ sed -i 's/^bool [^(]*$/static &/' extern.h
+ sed -i 's/^char [^(]*$/static &/' extern.h
+ sed -i 's/^piece_info_t [^(]*$/static &/' extern.h
+ sed -i 's/^city_info_t [^(]*$/static &/' extern.h
}
build() {