summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 438923a4323d..2a03369fc2ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase='vte3-notification'
pkgname=("${pkgbase}" 'vte-notification-common')
pkgver=0.46.1
-pkgrel=4
+pkgrel=5
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
arch=('i686' 'x86_64')
url='https://wiki.gnome.org/Apps/Terminal/VTE'
@@ -22,16 +22,19 @@ source=(
"https://download.gnome.org/sources/vte/${pkgver::4}/vte-${pkgver}.tar.xz"
"${_fpatchfile}::${_frepourl}/plain/${_fpatchfile}?h=${_frepobranch}"
'add-zsh-notfication-support.patch'
+ "gperf-fix.patch::https://git.gnome.org/browse/vte/patch/?id=1226f58cd97aa06f0ce58791153ca1f58e89658a"
)
sha256sums=(
'8800cf8bc259704a12ad1853fb0eb43bfe3857af15242e6fb9f2c3fd95b3f5c6'
'9238ca155af79ec4f55f13b82981ea97745c26e3fcc87ab6917a1d41b4b9d852'
'150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
+ '7a2b1c74da87df40507df8a41524209a7e8aa77250af2fd11153beb3999db139'
)
prepare () {
cd "vte-${pkgver}"
+ patch -p1 -i '../gperf-fix.patch'
patch -p1 -i "../${_fpatchfile}"
patch -p1 -i '../add-zsh-notfication-support.patch'
}