summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a03369fc2ba..1a2cf08e9167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase='vte3-notification'
pkgname=("${pkgbase}" 'vte-notification-common')
-pkgver=0.46.1
-pkgrel=5
+pkgver=0.48.2
+pkgrel=1
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
arch=('i686' 'x86_64')
url='https://wiki.gnome.org/Apps/Terminal/VTE'
@@ -16,25 +16,20 @@ makedepends=('intltool' 'gobject-introspection' 'gtk-doc' 'vala' 'gperf' 'glade'
options=('!emptydirs')
# Fedora patches: http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='http://pkgs.fedoraproject.org/cgit/rpms/vte291.git'
-_frepobranch='f25'
+_frepobranch='f26'
_fpatchfile='vte291-command-notify-scroll-speed.patch'
source=(
"https://download.gnome.org/sources/vte/${pkgver::4}/vte-${pkgver}.tar.xz"
"${_fpatchfile}::${_frepourl}/plain/${_fpatchfile}?h=${_frepobranch}"
'add-zsh-notfication-support.patch'
- "gperf-fix.patch::https://git.gnome.org/browse/vte/patch/?id=1226f58cd97aa06f0ce58791153ca1f58e89658a"
-)
-sha256sums=(
- '8800cf8bc259704a12ad1853fb0eb43bfe3857af15242e6fb9f2c3fd95b3f5c6'
- '9238ca155af79ec4f55f13b82981ea97745c26e3fcc87ab6917a1d41b4b9d852'
- '150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
- '7a2b1c74da87df40507df8a41524209a7e8aa77250af2fd11153beb3999db139'
)
+sha256sums=('c278b301edfe38b43baec1bccc86e225dacea5b670a96ca7ea55ca9a4b030690'
+ 'd32201c04d9f688195725bf76d7c618ae24178a2578da01c507d8216f082cf8e'
+ '150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a')
prepare () {
cd "vte-${pkgver}"
- patch -p1 -i '../gperf-fix.patch'
patch -p1 -i "../${_fpatchfile}"
patch -p1 -i '../add-zsh-notfication-support.patch'
}
@@ -50,7 +45,7 @@ build() {
}
package_vte3-notification(){
- depends=('gtk3' 'vte-notification-common')
+ depends+=('vte-notification-common')
provides=("vte3=${pkgver}")
conflicts=('vte3')
cd "vte-${pkgver}"
@@ -60,6 +55,7 @@ package_vte3-notification(){
}
package_vte-notification-common() {
+ depends=('sh')
pkgdesc='Common files used by vte and vte3'
arch=('any')
provides=("vte-common=${pkgver}")