summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c3492851c3e..3c26cd529516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Oleksii Filonenko <filalex77@gmail.com>
-pkgname=wallsplash
+pkgname=wallsplash-git
pkgver=0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Set unsplash wallpapers with colorschemes"
url="https://github.com/filalex77/wallsplash/"
license=('GPL')
arch=('x86_64' 'x86')
depends=('feh' 'wal-git' 'nodejs-unsplash-wallpaper')
-makedepends=('nodejs' 'npm')
-optdepends=()
-source=("$pkgname-$pkgver.tar.gz")
-sha1sums=(SKIP)
+makedepends=('nodejs' 'npm' 'git')
+provides=('wallsplash')
+source=("$pkgname"::'git+https://github.com/filalex77/wallsplash.git')
+sha256sums=(SKIP)
package() {
- install -d "$pkgdir/usr/bin"
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
install -Dm755 wallsplash \
"$pkgdir/usr/bin/wallsplash"
}