summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ddce52ea840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: James Williams <jowilliams12000 at gmail dot com>
+pkgname=wallust
+pkgver=2.9.0
+pkgrel=1
+pkgdesc="generate colors from an image"
+arch=('any')
+url="https://codeberg.org/explosion-mental/wallust"
+license=('custom:MIT')
+makedepends=('cargo')
+optdepends=('imagemagick')
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+sha256sums=('a802e217886fd9b6449865291ee5ef2057ce443d617db23958c5732bbc119dda')
+
+prepare() {
+ cd "$pkgname"-"$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd "$pkgname"-"$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "$pkgname"-"$pkgver"
+ install -Dm755 target/release/wallust -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/wallust/LICENSE"
+}