summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8c502550068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bruno Goncalves <bigbruno@gmail.com>
+
+pkgname=waydroid-biglinux
+pkgver=$(date +%y.%m.%d)
+pkgrel=$(date +%H%M)
+arch=('any')
+license=('GPL')
+url="https://github.com/biglinux/waydroid-biglinux"
+pkgdesc="Simplify waydroid usage"
+source=("git+https://github.com/biglinux/waydroid-biglinux.git")
+depends=(waydroid python-pyclip bigbashview)
+md5sums=(SKIP)
+
+package() {
+ # Verify default folder
+ if [ -d "${srcdir}/${pkgname}/${pkgname}" ]; then
+ InternalDir="${srcdir}/${pkgname}/${pkgname}"
+ else
+ InternalDir="${srcdir}/${pkgname}"
+ fi
+
+
+ # Copy files
+ if [ -d "${InternalDir}/usr" ]; then
+ cp -r "${InternalDir}/usr" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/etc" ]; then
+ cp -r "${InternalDir}/etc" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/opt" ]; then
+ cp -r "${InternalDir}/opt" "${pkgdir}/"
+ fi
+}