summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 22 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6759b2369c3b..a90cb4551374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,37 @@
-#Contributor:Andrea Tarocchi <valdar@email.it>
-#Maintainer: Andrea Tarocchi <valdar@email.it>
+#Contributor:Andrea Tarocchi <valdar9@protonmail.com>
+#Maintainer: Andrea Tarocchi <valdar9@protonmail.com>
pkgname=wesnoth-devel
-# when changing major version (i.e. 1.15 to 1.1X) remeber to updated the occurences in build() and package()
-pkgver=1.15.8
+#XXX: when changing major version (i.e. 1.15 to 1.1X) remeber to updated the occurences in build() and package()
+pkgver=1.15.9
pkgrel=1
pkgdesc="development version of a turn-based strategy game on a fantasy world"
-arch=('i686' 'x86_64')
+arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://www.wesnoth.org/"
license=('GPL')
-depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'pango' 'fribidi' 'lua' 'dbus' 'openssl' 'boost-libs' 'desktop-file-utils')
+depends=('sdl2'
+ 'sdl2_image'
+ 'sdl2_mixer'
+ 'sdl2_ttf'
+ 'pango'
+ 'fribidi'
+ 'dbus'
+ 'openssl'
+ 'boost-libs'
+ 'libpng')
optdepends=('python: some tools for UMC developers'
- 'python2: some tools for UMC developers'
'tk: for GUI.pyw, a gui for some of these tools'
'gettext: for creating translation files with wmlxgettext'
'python-pyenchant: spellchecking with wmllint'
'optipng: png optimization with wesnoth-optipng / woptipng'
'advancecomp: png optimization with wesnoth-optipng / woptipng'
- 'imagemagick: png optimization with wesnoth-optipng / woptipng'
- 'libpng: png screenshots')
+ 'imagemagick: png optimization with wesnoth-optipng / woptipng')
makedepends=('boost' 'scons' 'pkg-config')
checkdepends=('desktop-file-utils' 'appstream-glib')
install=${pkgname}.install
options=('!emptydirs')
#options=('!emptydirs' '!strip') #use this when building with debugging symbols
+
source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2"
"${pkgname}.desktop"
"wesnoth_editor-devel.desktop"
@@ -33,7 +41,7 @@ source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.t
"wesnothd-devel.service"
"wesnoth-devel.appdata.xml")
-md5sums=('845d08ac4f8d439ccf206f0dd6922ada'
+md5sums=('2709228549bac1d11ccb0814c2079daa'
'719df848ebda176f995051ef9da302c6'
'049a22a72074277e53484e3a530d1d69'
'251f487241afda73c048b4fb654ceda7'
@@ -42,8 +50,6 @@ md5sums=('845d08ac4f8d439ccf206f0dd6922ada'
'93f1afc41c66eb324a45ca26055f1507'
'eb0e7466413cd0cdf5ed535146e87f87')
-PKGEXT='.pkg.tar'
-
prepare() {
cd "$srcdir/wesnoth-$pkgver"
@@ -64,7 +70,7 @@ build() {
cd "$srcdir/wesnoth-$pkgver"
#the option build=debug can be useful if the game crashes and you would like to report a bug
- scons jobs=4 desktop_entry=False prefix=/usr version_suffix=-devel prefsdir=.wesnoth-devel \
+ scons jobs=4 desktop_entry=False prefix=/usr version_suffix=-devel \
docdir=/usr/share/doc/wesnoth-devel fifodir=/run/wesnothd-devel \
prefsdir=.local/share/wesnoth/1.15 \
appdata_file=False enable_lto=True wesnoth wesnothd
@@ -78,17 +84,17 @@ package(){
#INSTALLING of menu entry and icons and appstream information:
install -D -m644 "$srcdir/wesnoth-devel.desktop" "$pkgdir/usr/share/applications/wesnoth-devel.desktop"
- install -D -m644 "$srcdir/wesnoth-devel-icon.png" "$pkgdir/usr/share/pixmaps/$pkgname-icon.png"
+ install -D -m644 "$srcdir/wesnoth-devel-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname-icon.png"
install -D -m644 "$srcdir/wesnoth_editor-devel.desktop" "$pkgdir/usr/share/applications/wesnoth_editor-devel.desktop"
- install -D -m644 "$srcdir/wesnoth-devel_editor-icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}_editor-icon.png"
+ install -D -m644 "$srcdir/wesnoth-devel_editor-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/${pkgname}_editor-icon.png"
install -D -m644 "$srcdir/wesnothd-devel.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd-devel.conf"
install -D -m644 "$srcdir/wesnothd-devel.service" "$pkgdir/usr/lib/systemd/system/wesnothd-devel.service"
install -D -m644 "$srcdir/wesnoth-devel.appdata.xml" "$pkgdir/usr/share/metainfo/wesnoth-devel.appdata.xml"
- # add suffix to manpages (.6 is the file extension) and copy them in the right directory
+ # add suffix to manpages (IMPORTANT: .6 is the file extension!!!) and copy them in the right directory
for filename in "$pkgdir"/usr/share/man/{,*/}man6/wesnoth{,d}.6
do
mv "$filename" $(dirname $filename)/$(basename $filename .6)-1.15.6