summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 347cd804f3da..69ee0753d8d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Alex Mekkering <amekkering at gmail dot com>
+# Maintainer: Mansour Behabadi <mansour@oxplot.com>
+# Contributor: Alex Mekkering <amekkering at gmail dot com>
-pkgname=whsniff
-_pkgver=1.1
-pkgver=1.1.r10.920e107
-pkgrel=2
+pkgname=whsniff-git
+pkgver=1.1.r38.4894032
+pkgrel=1
pkgdesc="A command line utility that interfaces TI CC2531 USB dongle with Wireshark for capturing and displaying IEEE 802.15.4 traffic at 2.4 GHz."
arch=('x86_64')
-url='https://github.com/homewsn/whsniff.git'
+url='https://github.com/homewsn/whsniff'
license=('GPL')
depends=('libusb')
+provides=("whsniff=${pkgver}")
+conflicts=('whsniff')
+replaces=('whsniff<=1.1.r18')
makedepends=('sed')
source=( "${pkgname}::git+https://github.com/homewsn/whsniff.git" )
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- printf "${_pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "1.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {