summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2e5851cfeaf..fe312c72d50a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=wifi-heat-mapper
_name=whm
-pkgver=0.2.4
+pkgver=0.2.5
pkgrel=1
pkgdesc="A Python library for benchmarking Wi-Fi networks to create heatmaps"
arch=('any')
url="https://github.com/nischay-pro/wifi-heat-mapper"
license=('GPL3')
-depends=('python>=3.7' 'python-iperf3>=0.1.11' 'python-matplotlib>=3.4.0'
- 'python-tqdm>=4.55.0' 'python-pillow>=8.2.0' 'python-scipy>=1.6.0'
- 'python-numpy>=1.20.0' 'python-pysimplegui>=4.34.0')
-makedepends=('python-setuptools')
+depends=('python>=3.7' 'python-iperf3' 'python-matplotlib' 'python-tqdm'
+ 'python-pillow' 'python-scipy' 'python-numpy' 'python-pysimplegui')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'python-versioneer-518')
optdepends=('speedtest-cli')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('cd60e202157b27ff5eb4127d80946f15f4573e1ccc4f0f9e49c7eaaf014cf0d6')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('b8396cd52026dfe31ae4f6016303c362a48ed8f248fa5490bd1de24b363a5e52')
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ cd "$pkgname-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
}