summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e28ad7858c2..a5aaaaea97e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
pkgname=wispr
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Simple command-line tool to authenticate against a WISPr server"
url="https://github.com/wichert/wispr"
arch=('any')
license=('custom')
-depends=('python')
+depends=(python)
+makedepends=(python-setuptools)
source=(
- 'https://github.com/wichert/wispr/archive/release/1.0.tar.gz'
+ "wispr-${pkgver}.tar.gz::https://github.com/wichert/wispr/archive/release/${pkgver}.tar.gz"
'python3.patch'
'timeout.patch'
)
sha256sums=(
'ba9994abee90d51c9d65fbb61241694a610a0198c5c4a833f8d7bf9c346ebd41'
- '7f14a07b35f7625b90163352ef943d225ef4ba01a5aa172e67174157e1b4b2cf'
- '0cc5f11d022ff3c560f71ce7c7269dd55a50a31ba1ee9c230e0405801b777eb5'
+ '191677eac9a175c56cff40f7e41843e21660be2de5be3aab2c926d0f3f7bf6e6'
+ '2af11c057fceb909cfecbd08a63fcd8efcfa4fe6f94c70dc5e897b4d47435ec8'
)
prepare() {
@@ -32,6 +33,6 @@ build() {
package() {
cd "wispr-release-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}