summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index baea5306e74a..d5c5cbfb951c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,23 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: libernux <dutchman55@gmx.com>
pkgname=wmcalc
-pkgver=0.3
-pkgrel=4
+pkgver=0.6
+pkgrel=1
pkgdesc="Dockapp that performs all the functions (and eventually more) of a simple four function calculator"
arch=('i686' 'x86_64')
-#url="http://dockapps.windowmaker.org/file.php/id/130"
-url="http://web.archive.org/web/20121025065535/http://dockapps.windowmaker.org/file.php/id/130"
+url="http://www.dockapps.net/${pkgname}"
license=('GPL')
groups=('x11')
depends=('libxpm')
-#source=("http://dockapps.windowmaker.org/download.php/id/455/$pkgname-$pkgver.tar.gz")
-source=("$pkgname-$pkgver.tar.gz")
-md5sums=('23ecf19e956d19ef9dddb810989666c5')
+source=("http://www.dockapps.net/download/${pkgname}-${pkgver}.tar.gz")
+md5sums=('0d84c4e1cdb8742c5abf03a34ea03540')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd dockapps-*
make clean
make INCLUDES=-I/usr/include/X11
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
- install -Dm644 .wmcalc "$pkgdir/usr/share/doc/$pkgname/wmcalc.example"
- install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+ cd dockapps-*
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}