summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd34476815d6..05d1a5f179bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xcfun-pyscf
_name=xcfun
pkgver=1.x
-pkgrel=1
+pkgrel=2
pkgdesc="Exchange-Correlation functionals with arbitrary order derivatives (compatible to PySCF)"
arch=(i686 x86_64)
url="http://dftlibs.org/xcfun/"
@@ -10,11 +10,15 @@ license=('GPL3')
makedepends=(git cmake)
provides=(${_name}=$pkgver)
conflicts=(xcfun)
-source=($pkgname::git+https://github.com/dftlibs/xcfun.git#commit=355f42497a9cd17d16ae91da1f1aaaf93756ae8b)
-md5sums=('SKIP')
+source=(
+ "$pkgname::git+https://github.com/dftlibs/xcfun.git#commit=355f42497a9cd17d16ae91da1f1aaaf93756ae8b"
+ 'https://github.com/pyscf/pyscf/raw/master/pyscf/lib/libxcfun.patch'
+)
+sha256sums=('SKIP' '3ce121a0a90146daf3d5e5c3ee457fb004113eeb764489027e085a6b1cf98b06')
build() {
cd "$pkgname"
+ patch -p1 < ../libxcfun.patch
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=RELEASE -DBUILD_SHARED_LIBS=1 \