summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5353433c9958..d597a5fd952d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,34 @@
# Contributor: Andreas B. Wagner <andreas.wagner@lowfatcomputing.org>
pkgname=xdotool-git
-pkgver=3.20160805.1.r23.g08c8e2d
+pkgver=3.20160805.1.r24.g6523b5f
pkgrel=1
pkgdesc='Command-line X11 automation tool (git version)'
-arch=('i686' 'x86_64')
-url='http://www.semicomplete.com/projects/xdotool/'
+arch=('x86_64')
+url='https://www.semicomplete.com/projects/xdotool/'
license=('BSD')
depends=('libxtst' 'libxinerama' 'libxkbcommon')
makedepends=('git')
-provides=('xdotool' 'libxdo.so')
+provides=('xdotool')
conflicts=('xdotool' 'xdotool-svn')
replaces=('xdotool-svn')
-source=("$pkgname"::'git+https://github.com/jordansissel/xdotool.git')
+source=('git+https://github.com/jordansissel/xdotool.git')
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd xdotool
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgname"
+ cd xdotool
make WITHOUT_RPATH_FIX='1'
}
package() {
- cd "$pkgname"
+ cd xdotool
make PREFIX='/usr' INSTALLMAN='/usr/share/man' DESTDIR="$pkgdir" install
# remove execute bit from header file