summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b2f28eae278..a6fcbe8405b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,41 @@
+# Contributor: Alejandro Perez Mendez <alejandro.perez.mendez@gmail.com>
+
+_pkgname=xfce4-notifyd
pkgname=xfce4-notifyd-keyaction
-srcname=xfce4-notifyd
-pkgver=0.2.4
+pkgver=0.4.4
pkgrel=1
pkgdesc="Notification daemon for the Xfce desktop. Super+N executes the first action"
arch=('i686' 'x86_64')
-url="http://goodies.xfce.org/projects/applications/xfce4-notifyd"
+url="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
license=('GPL2')
groups=('xfce4-goodies')
depends=('libxfce4ui' 'libnotify' 'hicolor-icon-theme' 'libkeybinder3')
makedepends=('intltool')
-replaces=('xfce4-notifiyd')
conflicts=('xfce4-notifyd')
-provides=('notification-daemon')
-install=$srcname.install
-source=(http://archive.xfce.org/src/apps/$srcname/0.2/$srcname-$pkgver.tar.bz2
+provides=('xfce4-notifyd' 'notification-daemon')
+source=(https://archive.xfce.org/src/apps/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
keybinder.patch)
-sha256sums=('8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0'
- 'c6c040602ff207ebf3ed73edc50ae67d905485867bf79f11361c18ffc224cca1')
+sha256sums=('090571acf94c423003426cb779fb23e8545c68bab6485563b589c7def8a21b55'
+ '9fb16fe3806dc985b51002f13ac96c940252609b98b4f6a2647a7a01bf768f80')
-build() {
- cd "$srcdir/$srcname-$pkgver"
- patch -i ../../keybinder.patch -p1
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i ../keybinder.patch
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
./configure \
--prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
--disable-static \
--disable-debug
make
}
package() {
- cd "$srcdir/$srcname-$pkgver"
+ cd "$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}