summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a96dc4277d8a..4fa7986ea074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,30 @@
pkgname=xow
pkgver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Linux driver for the Xbox One wireless dongle'
arch=('x86_64')
url='https://github.com/medusalix/xow'
license=('GPL2')
depends=('libusb' 'cabextract')
conflicts=('xow-git')
-install=$pkgname.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/medusalix/xow/archive/v$pkgver.tar.gz")
md5sums=('37193261c48ec5d3e703f5a045e7427f')
build() {
cd "$pkgname-$pkgver"
- make BUILD=RELEASE
+ make PREFIX=/usr BUILD=RELEASE
+ make PREFIX=/usr BUILD=RELEASE xow.service
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR=$pkgdir/usr PREFIX="" install
+ make PREFIX=/usr DESTDIR=$pkgdir/ SYSDDIR=/usr/lib/systemd/system install
+
+ echo ""
+ echo "To enable and start the service:"
+ echo -e "\e[33msystemctl enable --now xow.service"
+ echo ""
+ echo -e "\e[33mA reboot might be required for xow to work correctly."
+ echo ""
}