summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c014899829fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nate Simon <aurpkg (at natesimon.net)>
+
+pkgname=xviewer
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A simple and easy to use image viewer. X-Apps Project."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gtk3' 'glib2' 'gnome-desktop' 'libpeas')
+makedepends=('gnome-common' 'libgnomeui' 'libgnome' 'libglade' 'gobject-introspection')
+provides=($_pkgname)
+conflicts=('xviewer-git')
+url='https://github.com/linuxmint/xviewer'
+install=xviewer.install
+
+source=("https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('4a193ddeffb1f2b19668cdf8387f3c71')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ gnome-autogen.sh --prefix="/usr" \
+ --localstatedir="/var" \
+ --libexecdir="/usr/lib/xviewer"
+ make
+}
+
+package(){
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}
+