summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b304b880ac31..c3e037648a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgbase=yafu
pkgname=yafu-git
-pkgrel=1
-pkgver=r468.ca48c65
+pkgrel=2
+pkgver=r615.93a23e5
pkgdesc="Automated integer factorization."
url=https://github.com/bbuhrow/yafu
license=("MIT")
@@ -19,13 +19,19 @@ source=(
"git+https://github.com/bbuhrow/ytools.git"
"git+https://github.com/bbuhrow/ysieve.git"
msieve::"svn+svn://svn.code.sf.net/p/msieve/code/trunk"
+ "avx_ecm_main.patch"
)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '2fa4529955996166f4d258e2cb1a93685a4a8485129314d44fa3e140ae97e595')
prepare() {
cd ${srcdir}/yafu
sed -i "s%^LIBS += -lecm /users/buhrow/src%#LIBS += -lecm /users/buhrow/src%" Makefile
sed -i "s/^\#LIBS += -lecm -lgmp -lytools -lysieve/LIBS += -lecm -lgmp -lytools -lysieve/" Makefile
+ patch --forward --strip=1 --input=../avx_ecm_main.patch
}
pkgver() {
@@ -38,19 +44,19 @@ pkgver() {
build() {
cd ${srcdir}/ytools
- make CC=gcc
+ make CC=gcc CFLAGS="$CFLAGS -Wno-error=implicit-function-declaration"
cp libytools.a ${srcdir}/ysieve/
cd ${srcdir}/ysieve
- make CC=gcc
+ make CC=gcc CFLAGS="$CFLAGS -g -O3 -fomit-frame-pointer -Wall -I. -I../ytools -Wno-error=incompatible-pointer-types"
cp libytools.a ${srcdir}/yafu/
cp libysieve.a ${srcdir}/yafu/
-
+
cd ${srcdir}/msieve
make all NO_ZLIB=1
cd ${srcdir}/yafu
- make yafu CC=gcc NFS=1
+ make yafu CC=gcc NFS=1 CFLAGS="$CFLAGS -g -m64 -std=gnu99 -DUSE_SSE2 -fno-common -DUSE_NFS -O2 -fomit-frame-pointer -Wall -I. -Iinclude -Itop/aprcl -Itop/cmdParser -Itop/ -Ifactor/gmp-ecm -I../ysieve -I../ytools -I../msieve/zlib -Wno-error=implicit-function-declaration -Wno-error=incompatible-pointer-types -Wno-error=return-mismatch"
}
package() {