summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9da11d561a0..f179656b526c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,39 @@
# Contributors: Frederic Bezies, Ronan Rabouin
pkgname=yamagi-quake2-ctf
-pkgver=1.09
+pkgver=1.10
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Three Wave Capture The Flag for yamagi-quake2"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
-makedepends=('cmake' 'ninja')
source=("http://deponie.yamagi.org/quake2/${pkgname#*-}-$pkgver.tar.xz"
"$pkgname.sh"
"$pkgname.desktop")
-sha256sums=('c57faed3e6e78091f836dc8bfe522021eb9f1e86e8bb9690608549c79ebbb073'
+sha256sums=('f4cb494dd3fe36b012e547524157dac4222c5f45d1dcd713e6abdbf981e8fc23'
'9a9abd8d720a719180713163261fed154ec34787c82dda2b9465aefd9890b64c'
'1191c20ea0e7609d28b44d678ff02b2f06b95a7037d1adfd02e963a62b8f3af2')
build() {
- rm -rf build
- cmake ${pkgname#*-}-$pkgver -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -GNinja
- cmake --build build
+ make -C ${pkgname#*-}-$pkgver
}
package() {
- # game library
- install -Dm644 build/Release/game.so "$pkgdir"/usr/lib/yamagi-quake2/ctf/game.so
-
cd ${pkgname#*-}-$pkgver
+ # game library
+ install -Dm644 -t "$pkgdir"/usr/lib/yamagi-quake2/ctf release/game.so
+
# game launcher
install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
# doc
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkgname README
# desktop entry
- install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkgname.desktop
# license
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}