summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8be5c6cd6b17..106faa95b2f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,18 @@ arch=('x86_64')
url='https://codeberg.org/dnkl/yambar'
license=('MIT')
depends=(
+ 'alsa-lib'
+ 'fontconfig'
+ 'pixman'
+ 'wayland'
+ 'wayland-protocols'
'xcb-util-cursor'
+ 'xcb-util-wm'
+ 'xorgproto'
)
makedepends=(
'cmake'
+ 'git'
'libmpdclient'
'libyaml'
'meson'
@@ -22,9 +30,7 @@ source=("${pkgname}-${pkgver}.tar.gz::https://codeberg.org/dnkl/${pkgname}/archi
sha256sums=('9ddf0bd7a708445697b4bf2f1d6d0fe5c29c5c7cd6df6058a739fe89413bd2c7')
prepare() {
- rm -rf "${srcdir}"
- mkdir -p "${srcdir}"
- bsdtar -xf "../${pkgname}-${pkgver}.tar.gz" -C "${srcdir}"
+ makepkg -Cc
cd yambar