summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bac0ead80325..3a5ce48ab154 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=ydcv-rs-git
_pkgname="ydcv-rs"
pkgdesc="A Rust version of ydcv."
-pkgver=0.4.7.157
-pkgrel=1
+pkgver=0.6.1.203
+pkgrel=2
arch=('i686' 'x86_64')
conflicts=("ydcv")
provides=("ydcv")
@@ -14,6 +14,9 @@ makedepends=('git' 'cargo' 'python')
source=('git+https://github.com/farseerfc/ydcv-rs.git')
sha256sums=('SKIP')
+#disable lto for https://github.com/briansmith/ring/issues/1444
+options=('!lto')
+
pkgver() {
cd $_pkgname
echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
@@ -24,6 +27,11 @@ build() {
cargo build --release
}
+check() {
+ cd $_pkgname
+ cargo test --release
+}
+
package() {
cd $_pkgname
install -D -m755 "$srcdir/$_pkgname/target/release/ydcv-rs" "$pkgdir/usr/bin/ydcv"