summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1c228652152
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+_reponame=ydweb
+pkgname=$_reponame-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Console-based dictionary with contents crawled from the youdao website; offline dictionaries with common words are available."
+license=(GPL3)
+arch=("i686" "x86_64")
+url="https://github.com/purboo/ydweb"
+depends=(python-requests python-pyquery python-prompt_toolkit)
+source=("git://github.com/purboo/ydweb.git")
+md5sums=("SKIP")
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/share"
+ cp -r "${_reponame}" "${pkgdir}/usr/share/"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -sf "/usr/share/${_reponame}/ydweb.py" "${pkgdir}/usr/bin/ydweb"
+}
+