summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40929a07840b..723fe5e8f0f4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r19504.3843995ce
+pkgver=r19743.5b2fa8dd4
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
@@ -48,7 +48,6 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
'git+https://github.com/ReinUsesLisp/sirit'
'git+https://github.com/yuzu-emu/mbedtls'
- 'git+https://github.com/nih-at/libzip.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/xiph/opus.git'
'git+https://git.ffmpeg.org/ffmpeg.git'
@@ -75,7 +74,6 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -86,7 +84,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,libzip/libzip,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
+ for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
git submodule update
@@ -119,9 +117,10 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DENABLE_QT_TRANSLATION=ON \
-DYUZU_USE_QT_WEB_ENGINE=ON \
+ -DYUZU_USE_EXTERNAL_SDL2=OFF \
-DUSE_DISCORD_PRESENCE=ON \
+ -DENABLE_QT_TRANSLATION=ON \
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON
make
}