summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD147
1 files changed, 67 insertions, 80 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b6bd90bfb8e..6e963b99abe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,109 +1,96 @@
-# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
-_pkgbase=zsh
pkgbase=zsh-git
pkgname=('zsh-git' 'zsh-doc-git')
-pkgver=5.2.r502.ge35dcae
+pkgver=5.9.r431.gc7ae37016
pkgrel=1
-arch=('i686' 'x86_64')
-url='http://www.zsh.org/'
+arch=('x86_64')
+url='https://www.zsh.org/'
license=('custom')
-makedepends=('git' 'yodl' 'texinfo' 'texlive-plainextra' 'pcre' 'libcap' 'gdbm')
+makedepends=('gdbm' 'git' 'libcap' 'pcre2' 'texlive-plaingeneric' 'yodl')
source=('zsh::git://git.code.sf.net/p/zsh/code'
'zprofile')
-md5sums=('SKIP'
- '24a9335edf77252a7b5f52e079f7aef7')
+sha256sums=('SKIP'
+ '230832038c3b8f67fdb1b284ac5f68d709cdb7f1bc752b0e60657b9b9d091045')
pkgver() {
- cd "${srcdir}/${_pkgbase}"
-
- if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- printf '%s.r%s.g%s' \
- "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
- "$(git rev-list --count ${GITTAG}..)" \
- "$(git log -1 --format='%h')"
- else
- printf '0.r%s.g%s' \
- "$(git rev-list --count master)" \
- "$(git log -1 --format='%h')"
- fi
+ cd zsh
+ git describe --tags | sed 's/zsh-//;s/-/.r/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_pkgbase}"
+ cd zsh
+
+ # Set correct keymap path
+ sed -i 's#/usr/share/keymaps#/usr/share/kbd/keymaps#g' Completion/Unix/Command/_loadkeys
- # Set correct keymap path
- sed -i 's#/usr/share/keymaps#/usr/share/kbd/keymaps#g' Completion/Unix/Command/_loadkeys
+ # Remove unneeded and conflicting completion scripts
+ for _fpath in AIX BSD Cygwin Darwin Debian Mandriva openSUSE Redhat Solaris; do
+ rm -rf Completion/$_fpath
+ sed 's#\s*Completion/'$_fpath'/\*/\*##g' -i Src/Zle/complete.mdd
+ done
- # Fix usb.ids path
- sed -i 's#/usr/share/misc/usb.ids#/usr/share/hwdata/usb.ids#g' Completion/Linux/Command/_lsusb
+ rm Completion/Linux/Command/_pkgtool
- # Remove unneeded and conflicting completion scripts
- for _fpath in AIX BSD Cygwin Darwin Debian Mandriva openSUSE Redhat Solaris; do
- rm -rf Completion/$_fpath
- sed "s#\s*Completion/$_fpath/\*/\*##g" -i Src/Zle/complete.mdd
- done
- rm -f Completion/Linux/Command/_{pkgtool,rpmbuild,yast}
- rm -f Completion/Unix/Command/_{osc,systemd}
+ # regenerate configure script
+ ./Util/preconfig
}
build() {
- cd "${srcdir}/${_pkgbase}"
-
- ./Util/preconfig
- ./configure --prefix=/usr \
- --docdir=/usr/share/doc/zsh \
- --htmldir=/usr/share/doc/zsh/html \
- --enable-etcdir=/etc/zsh \
- --enable-zshenv=/etc/zsh/zshenv \
- --enable-zlogin=/etc/zsh/zlogin \
- --enable-zlogout=/etc/zsh/zlogout \
- --enable-zprofile=/etc/zsh/zprofile \
- --enable-zshrc=/etc/zsh/zshrc \
- --enable-maildir-support \
- --with-term-lib='ncursesw' \
- --enable-multibyte \
- --enable-function-subdirs \
- --enable-fndir=/usr/share/zsh/functions \
- --enable-scriptdir=/usr/share/zsh/scripts \
- --with-tcsetpgrp \
- --enable-pcre \
- --enable-cap \
- --enable-zsh-secure-free
- make
-
- cd "${srcdir}/${_pkgbase}/Doc"
-
- make zsh.pdf
+ cd zsh
+
+ ./configure --prefix=/usr \
+ --docdir=/usr/share/doc/zsh \
+ --htmldir=/usr/share/doc/zsh/html \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-maildir-support \
+ --with-term-lib='ncursesw' \
+ --enable-multibyte \
+ --enable-function-subdirs \
+ --enable-fndir=/usr/share/zsh/functions \
+ --enable-scriptdir=/usr/share/zsh/scripts \
+ --with-tcsetpgrp \
+ --enable-pcre \
+ --enable-gdbm \
+ --enable-cap \
+ --enable-zsh-secure-free
+ make
+
+ make -C Doc zsh.pdf
}
check() {
- cd "${srcdir}/${_pkgbase}"
- HOME="${srcdir}" make check
+ cd zsh
+ HOME="${srcdir}" make check
}
package_zsh-git() {
- pkgdesc='A very advanced and programmable command interpreter (shell) for UNIX'
- depends=('pcre' 'libcap' 'gdbm')
- conflicts=('zsh')
- provides=("zsh=${pkgver%%.r*}")
- backup=('etc/zsh/zprofile')
- install=zsh.install
-
- cd "${srcdir}/${_pkgbase}"
- make DESTDIR="${pkgdir}/" install
- install -D -m644 "${srcdir}/zprofile" "${pkgdir}/etc/zsh/zprofile"
- install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ pkgdesc='A very advanced and programmable command interpreter (shell) for UNIX'
+ depends=('pcre2' 'libcap' 'gdbm')
+ conflicts=('zsh')
+ provides=('zsh')
+ backup=('etc/zsh/zprofile')
+ install=zsh.install
+
+ cd zsh
+ make DESTDIR="${pkgdir}/" install
+ install -D -m644 "${srcdir}/zprofile" "${pkgdir}/etc/zsh/zprofile"
+ install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_zsh-doc-git() {
- pkgdesc='Info, HTML and PDF format of the ZSH documentation'
- conflicts=('zsh-doc')
- provides=('zsh-doc')
-
- cd "${srcdir}/${_pkgbase}"
- make DESTDIR="${pkgdir}/" install.info install.html
- install -D -m644 Doc/zsh.pdf "${pkgdir}/usr/share/doc/zsh/zsh.pdf"
- install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ pkgdesc='Info, HTML and PDF format of the ZSH documentation'
+ conflicts=('zsh-doc')
+ provides=('zsh-doc')
+
+ cd zsh
+ make DESTDIR="${pkgdir}/" install.info install.html
+ install -D -m644 Doc/zsh.pdf "${pkgdir}/usr/share/doc/zsh/zsh.pdf"
+ install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}