summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 998b262b72d8..820fdfb22a60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=zutty-git
-pkgver=57.ccccbad
-pkgrel=2
+pkgver=140.7e481c0
+pkgrel=1
pkgdesc='Terminal emulator'
arch=(x86_64)
-url='https://tomscii.sig7.se/zutty'
+url='https://tomscii.sig7.se/zutty/'
license=(GPL3)
conflicts=(zutty)
-depends=(freetype2 libglvnd libxmu)
+depends=(freetype2 libglvnd libxmu xorg-fonts-misc)
makedepends=(git python)
-source=('git+https://github.com/tomszilagyi/zutty')
+source=('git+https://git.hq.sig7.se/zutty.git')
sha256sums=(SKIP)
pkgver() {
@@ -27,4 +28,13 @@ build() {
package() {
cd zutty
python ./waf --destdir="$pkgdir" install
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ cp -v doc/* "$pkgdir/usr/share/doc/$pkgname"
+ cd icons
+ install -Dm644 zutty.desktop "$pkgdir/usr/share/applications/zutty.desktop"
+ install -Dm644 zutty.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/zutty.svg"
+ for res in 16x16 32x32 48x48 64x64 96x96 128x128; do
+ install -Dm644 zutty_$res.png "$pkgdir/usr/share/icons/hicolor/$res/apps/zutty.png"
+ done
+
}