summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 16 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cc593b877e4..b92b7c7f2b48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_pkgname=zypper
pkgname=${_pkgname}-git
-pkgver=1.14.41.18.g2d3baa94
+pkgver=1.14.52.37.g01e16dc9
pkgrel=1
pkgdesc="World's most powerful command line package manager"
arch=('x86_64')
-url="https://github.com/openSUSE/${_pkgname}"
+url='http://en.opensuse.org/Portal:Zypper'
license=('GPL')
depends=(
'augeas'
@@ -20,23 +20,13 @@ makedepends=(
'boost'
'cmake'
'git'
- 'ninja'
-)
-provides=(
- "${_pkgname}"
- 'apt'
-)
-conflicts=(
- "${_pkgname}"
- 'apt'
-)
-source=(
- "${pkgname}::git+https://github.com/openSUSE/${_pkgname}.git"
- 'make-ZyppCommon-cmake-module-includable.patch')
-sha256sums=(
- 'SKIP'
- 'f5cdd85109c58d786f1124fa3cab1c5431a93a8d87a59117eac257c6e4698ae7'
)
+provides=("${_pkgname}" 'apt')
+conflicts=("${provides[@]}")
+source=("${pkgname}::git+https://github.com/openSUSE/${_pkgname}.git"
+ 'make-ZyppCommon-cmake-module-includable.patch')
+sha256sums=('SKIP'
+ 'f5cdd85109c58d786f1124fa3cab1c5431a93a8d87a59117eac257c6e4698ae7')
pkgver() {
cd "${pkgname}"
@@ -50,19 +40,19 @@ prepare() {
build() {
cmake \
- -B build \
- -S "${pkgname}" \
- -G Ninja \
- -D CMAKE_INSTALL_PREFIX=/usr \
- -D CMAKE_BUILD_TYPE=Release \
- -D LIB=lib \
- -D ZYPP_PREFIX=/usr \
+ -B build \
+ -S "${pkgname}" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D LIB=lib \
+ -D ZYPP_PREFIX=/usr \
+ -D ENABLE_BUILD_TESTS=ON
cmake --build build
}
check() {
- ARGS="-V" cmake --test build
+ ctest --test-dir build
}
package() {