summarylogtreecommitdiffstats
path: root/add-stubdom-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'add-stubdom-fixes.patch')
-rw-r--r--add-stubdom-fixes.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/add-stubdom-fixes.patch b/add-stubdom-fixes.patch
new file mode 100644
index 000000000000..e16d5fb692ab
--- /dev/null
+++ b/add-stubdom-fixes.patch
@@ -0,0 +1,12 @@
+diff -Naur orig.xen-4.16.1/stubdom/Makefile xen-4.16.1/stubdom/Makefile
+--- orig.xen-4.16.1/stubdom/Makefile 2022-05-16 09:41:38.409898784 -0700
++++ xen-4.16.1/stubdom/Makefile 2022-05-16 09:43:31.891076356 -0700
+@@ -241,6 +241,7 @@
+ patch -d $@ -p1 < vtpm_extern.patch
+ patch -d $@ -p1 < vtpm-microsecond-duration.patch
+ patch -d $@ -p1 < vtpm-command-duration.patch
++ patch -d $@ -p1 < vtpm-gcc12-fixes.patch
+ patch -d $@ -p1 < vtpm-tpm_bn_t-addr.patch
+ mkdir $@/build
+ cd $@/build; CC=${CC} $(CMAKE) .. -DCMAKE_C_FLAGS:STRING="-std=c99 -DTPM_NO_EXTERN $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -Wno-declaration-after-statement"
+ touch $@