summarylogtreecommitdiffstats
path: root/build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'build.patch')
-rw-r--r--build.patch18
1 files changed, 1 insertions, 17 deletions
diff --git a/build.patch b/build.patch
index 172991b33e1d..b61e09a021ae 100644
--- a/build.patch
+++ b/build.patch
@@ -2,15 +2,8 @@ diff --git a/kalk/Cargo.toml b/kalk/Cargo.toml
index 99915ea..1d00a9c 100644
--- a/kalk/Cargo.toml
+++ b/kalk/Cargo.toml
-@@ -14,10 +14,14 @@ categories = ["mathematics", "parser-implementations"]
- crate-type = ["cdylib", "rlib"]
-
- [dependencies]
--rug = { version = "1.17.0", features = ["float"], optional = true }
-+rug = { version = "1.24.0", features = ["float"], optional = true }
- lazy_static = "1.4.0"
+@@ -19,4 +19,9 @@
wasm-bindgen = "0.2.69"
--gmp-mpfr-sys = { version = "1.4.9", optional = true }
+
+[dependencies.gmp-mpfr-sys]
+version = "1.6.2"
@@ -19,12 +12,3 @@ index 99915ea..1d00a9c 100644
[dev-dependencies]
wasm-bindgen-test = "0.3.19"
-@@ -25,7 +29,7 @@ test-case = "1.0.0"
- regex = "1"
-
- [features]
--default = ["rug", "gmp-mpfr-sys"]
-+default = ["rug"]
-
- # Breaks when optimizing for some reason.
- [package.metadata.wasm-pack.profile.release