summarylogtreecommitdiffstats
path: root/build_installer.sh
diff options
context:
space:
mode:
Diffstat (limited to 'build_installer.sh')
-rwxr-xr-xbuild_installer.sh23
1 files changed, 22 insertions, 1 deletions
diff --git a/build_installer.sh b/build_installer.sh
index 8de730fb04f8..cdcf37f48776 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -3,24 +3,32 @@
set -e
printf "\n\n Buildscript for creating the distribution independed installer\n"
-printf " with all dependencies and optional evelauncher archive included.\n\n"
+printf " with all dependencies and optional evelauncher and dxvk archive included.\n\n"
version=$(grep ^pkgver PKGBUILD | cut -d= -f2) || exit 1
release=$(grep ^pkgrel PKGBUILD | cut -d= -f2) || exit 1
arch=$(uname -m)
+dvcsum=""
elcsum=""
mscsum="ca66a6113ce98152b85c8d847949f8c90ab9ba798e106bfc225d4ed3c2e2e3e2"
rcsum=""
pshal=$(grep -n ^sha256sum PKGBUILD | cut -d: -f1)
psrcl=$(grep -n ^source PKGBUILD | cut -d: -f1)
+pdvsl=$(grep -n dxvk-1.7.tar.gz\" PKGBUILD | cut -d: -f1)
pelsl=$(grep -n evelauncher-\${pkgver}.tar.gz\" PKGBUILD | cut -d: -f1)
+pdfsl=$(expr $pdvsl - $psrcl)
pofsl=$(expr $pelsl - $psrcl)
+pdvcs=$(expr $pshal + $pdfsl)
pelcs=$(expr $pshal + $pofsl)
plc=1
while read pline ;do
+ if [ $plc -eq $pdvcs ] ;then
+ dvcsum=${pline#*\'}
+ dvcsum=${dvcsum%%\'*}
+ fi
if [ $plc -eq $pelcs ] ;then
elcsum=${pline#*\'}
elcsum=${elcsum%%\'*}
@@ -73,6 +81,7 @@ sed -i s,ELVER=\"\",ELVER=\"$version\", evesetup/evelauncher.sh
cp ../setup.sh.in evesetup/setup.sh
sed -i s,elver=\"\",elver=\"$version\", evesetup/setup.sh
sed -i s,elcsum=\"\",elcsum=\"$elcsum\", evesetup/setup.sh
+sed -i s,dvcsum=\"\",dvcsum=\"$dvcsum\", evesetup/setup.sh
chmod a+x evesetup/setup.sh
echo "done."
@@ -88,6 +97,18 @@ if [ -f "../evelauncher-$version.tar.gz" ] ;then
else
printf "\nEVE Launcher archive not found, will be downloaded during the setup process.\n"
fi
+if [ -f "../dxvk-1.7.tar.gz" ] ;then
+ printf "\nFound DXVK archive..."
+ rcsum="$(sha256sum ../dxvk-1.7.tar.gz | cut -d' ' -f1)"
+ if [ "$rcsum" = "$dvcsum" ] ;then
+ cp ../dxvk-1.7.tar.gz evesetup/ && \
+ echo "added."
+ else
+ echo "skipped, checksum mismatch."
+ fi
+else
+ printf "\nDXVK archive not found, will be downloaded during the setup process.\n"
+fi
printf "\nBuild self-extractable archive evesetup-$version-$release-$arch.run\n\n"
./makeself.sh --tar-quietly evesetup/ ../evesetup-$version-$release-$arch.run \
"EVE Online Launcher Setup $version-$release" ./setup.sh