summarylogtreecommitdiffstats
path: root/cocotb.install
diff options
context:
space:
mode:
Diffstat (limited to 'cocotb.install')
-rw-r--r--cocotb.install18
1 files changed, 18 insertions, 0 deletions
diff --git a/cocotb.install b/cocotb.install
new file mode 100644
index 000000000000..7ffdc15635bf
--- /dev/null
+++ b/cocotb.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo ''
+ echo ''
+ echo 'cocotb relies on some environment variables.'
+ echo ' You need to set COCOTB="/usr/local/cocotb-1.1.0"'
+ echo ''
+ echo 'A simple Makefile could look like this:'
+ echo '--------------------------------------------------------------------------------'
+ echo 'export USER_DIR:=$(shell pwd) # Without this cocotb will try to build in /usr/local...'
+ echo 'include $(COCOTB)/makefiles/Makefile.inc'
+ echo 'include $(COCOTB)/makefiles/Makefile.sim'
+ echo 'VERILOG_SOURCES = my_example.sv'
+ echo 'TOPLEVEL = my_example'
+ echo 'MODULE=test_my_example'
+ echo '--------------------------------------------------------------------------------'
+ echo ''
+ echo ''
+}