summarylogtreecommitdiffstats
path: root/disable-errors.patch
diff options
context:
space:
mode:
Diffstat (limited to 'disable-errors.patch')
-rw-r--r--disable-errors.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/disable-errors.patch b/disable-errors.patch
new file mode 100644
index 000000000000..34d497dd56ba
--- /dev/null
+++ b/disable-errors.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 9cfe65be..3bb64f98 100644
+--- a/Makefile
++++ b/Makefile
+@@ -125,7 +125,7 @@ endif
+ # Provide default CC and CFLAGS for firmware builds; if you have any -D flags,
+ # please add them after this point (e.g., -DVBOOT_DEBUG).
+ DEBUG_FLAGS := $(if $(filter-out 0,${DEBUG}),-g -Og,-g -Os)
+-WERROR := -Werror
++WERROR :=
+ FIRMWARE_FLAGS := -nostdinc -ffreestanding -fno-builtin -fno-stack-protector
+ COMMON_FLAGS := -pipe ${WERROR} -Wall -Wstrict-prototypes -Wtype-limits \
+ -Wundef -Wmissing-prototypes -Wno-trigraphs -Wredundant-decls -Wshadow \