summarylogtreecommitdiffstats
path: root/force-system-libhandy.patch
diff options
context:
space:
mode:
Diffstat (limited to 'force-system-libhandy.patch')
-rw-r--r--force-system-libhandy.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/force-system-libhandy.patch b/force-system-libhandy.patch
new file mode 100644
index 000000000000..458befb3ddaf
--- /dev/null
+++ b/force-system-libhandy.patch
@@ -0,0 +1,39 @@
+diff --u a/meson.build b/meson.build
+--- a/meson.build
++++ b/meson.build
+@@ -88,7 +88,7 @@ iso_codes = dependency('iso-codes')
+ javascriptcoregtk = dependency('javascriptcoregtk-4.0', version: '>=' + target_webkit)
+ json_glib = dependency('json-glib-1.0', version: '>= 1.0')
+ libcanberra = dependency('libcanberra', version: '>= 0.28')
+-libhandy = dependency('libhandy-0.0', version: '>= 0.0.9', required: false)
++libhandy = dependency('libhandy-0.0', version: '>= 0.0.9')
+ libmath = cc.find_library('m')
+ libsecret = dependency('libsecret-1', version: '>= 0.11')
+ libsoup = dependency('libsoup-2.4', version: '>= 2.48')
+@@ -108,26 +108,6 @@ if not enchant.found()
+ enchant = dependency('enchant', version: '>=1.6')
+ endif
+
+-# Handy isn't necessarily packaged by distros, so fall back to a
+-# subproject until it is.
+-if not libhandy.found()
+- libhandy_subproj = subproject(
+- 'libhandy',
+- default_options: [
+- 'examples=false',
+- 'glade_catalog=disabled',
+- 'tests=false',
+- ]
+- )
+-
+- libhandy = declare_dependency(
+- dependencies: [
+- libhandy_subproj.get_variable('libhandy_dep'),
+- libhandy_subproj.get_variable('libhandy_vapi'),
+- ]
+- )
+-endif
+-
+ # Libunwind system dependencies above ensures appropriate versions,
+ # but this declared depencency is what we actually build against so we
+ # can include the custom VAPI correctly. We need to add unwind_lib to